Guias Canvas (Portuguese - Brazil)Guia Básico do Canvas Informações geraisQuais são os requisitos de navegador e computador para o Canvas?

Quais são os requisitos de navegador e computador para o Canvas?

Para um melhor desempenho, o Canvas deve ser usado na versão principal anterior ou anterior do Chrome, Firefox, Edge ou Safari. Por ser construído utilizando padrões web, o Canvas pode funcionar no Windows, Mac, Linux, iOS, Android, ou qualquer outro dispositivo com um navegador web moderno.

O Canvas requer apenas um sistema operacional que possa executar os mais recentes navegadores compatíveis. O sistema operacional do computador deve ser atualizado com as atualizações e upgrades de segurança recomendados mais recentes. 

Navegadores suportados

O Canvas suporta os lançamentos atuais e o primeiro lançamento principal prévio dos seguintes navegadores:

  • Chrome 94 e 95
  • Firefox 92 e 93 (Extended Releases não são suportados*)
  • Edge 94 e 95
  • Navegador Respondus LockDown (suportando os mais recentes requisitos do sistema)
  • Safari 14 e 15 (somente para Macintosh)

Você pode verificar se o navegador que está usando está atualizado usando a ferramenta de verificação de navegador na etapa abaixo.

Você deve sempre usar a versão mais atual do seu navegador preferido. Seu navegador irá te avisar se existir uma nova versão disponível.

Nota: Safari 13.1 e versões posteriores contêm uma atualização que pode causar problemas no download de arquivos, exibição de imagens e reprodução de alertas de bate-papo no Canvas. Os engenheiros do Canvas estão atualmente trabalhando em uma solução para esse problema. Até então, você pode evitar erros com arquivos, imagens e alertas, desativando a prevenção de rastreamento entre sites no Safari ao usar o Canvas. Se desativar o rastreamento entre sites não resolver esses problemas, tente um dos outros navegadores compatíveis.

Banner de navegador não suportado

Alguns navegadores suportados podem produzir um banner dizendo Seu navegador não atende aos requisitos mínimos para o Canvas (Your browser does not meet the minimum requirements for Canvas). Se você atualizou seu navegador, mas ainda continua vendo essa mensagem de alerta, tente sair do Canvas e excluir os cookies de seu navegador.

Navegador Enterprise com lançamentos estendidos

Chrome e Firefox oferecem versões estendidas de lançamento para a organização que gerencia desktops de clientes. Chrome ESR pode ser mantido atualizado com a versão completa existente do Chrome em qualquer momento. Contudo, Firefox ESR só é atualizado a cada sétima versão principal, fazendo com que o Firefox ESR sobreponha versões desatualizadas. A página Firefox ESR observa que ESR pode não ser suportado em todo aplicativo web devido a este atraso de lançamento da versão. Instituições que utilizam o Firefox ESR devem considerar a implantação o último lançamento para assegurarem a melhor experiência de usuário do Canvas.

* Para versões de navegadores com lançamentos estendidos, o banner de aviso ainda é aplicável e é exibido no Canvas para qualquer navegador abaixo do requisito de versão mínima.

Comportamentos Conhecidos dos Navegadores

Como todas as funcionalidades do Canvas, comportamentos contrários relacionados a navegadores são priorizados pelas nossas equipes de produtos, e alguns comportamentos na versão anterior podem não ser resolvidos. Se um comportamento existir na versão anterior do navegador que não exista na versão atual, a melhor solução é atualizar para a versão de navegador mais nova.

Acessibilidade

O Canvas está comprometido com a Web Accessibility Initiative da W3C. Para saber sobre o leitor de tela suportado e combinações de navegadores, consulte o documento Padrões de acessibilidade do Canvas.

JavaScript

É necessário que o JavaScript esteja habilitado para usar o Canvas.

Plugins e Extensões de Navegador

Alguns plugins ou extensões de navegador podem entrar em conflito com o Canvas e afetar a funcionalidade. Se você vivenciar um comportamento que não permite que você veja ou participe de cursos do Canvas, verifique se você desativou todas as extensões ou plugins que interagem diretamente com o navegador da Web.

Para solucionar problemas, considere fazer logon no Canvas usando uma janela de navegador anônima ou privada, que fornecerá uma sessão do navegador sem qualquer histórico de navegação ou de pesquisa anterior, cookies do navegador associados ou outros fatores que possam interferir com o navegador. Se você for capaz de exibir e participar do Canvas usando uma janela de navegador anônima ou privada, o comportamento que está ocorrendo provavelmente está relacionado ao navegador e não ao Canvas.

Configurações de Privacidade no Navegador

Para assegurar a segurança do navegador, siga todas as políticas de segurança do navegador estabelecidas pela sua instituição, especialmente se você estiver usando o Canvas em um computador fornecido pela instituição.

Ao exibir conteúdo, o padrão do Canvas é a preferência definida por um navegador específico. Alguns navegadores podem ocasionalmente fazer modificações nas configurações de privacidade para proteger usuários de um possível conteúdo inseguro. Conteúdo não protegido é identificado com o prefixo http:// na URL e pode criar conteúdo misto em sua página do Canvas. Conteúdo seguro é identificado com o prefixo https:// na URL. Para obter a melhor experiência do usuário, o conteúdo deve ser seguro para evitar conflitos de navegador.

  • Se você for um administrador do Canvas, conteúdo inseguro pode ser causado pela hospedagem de um arquivo JS/CSS inseguro fora do Canvas. Se carregamentos personalizados forem suportados para a sua conta, você pode hospedar o seu arquivo no Editor de Temas do Canvas, que resolverá quaisquer conflitos de navegador.
  • Se você for um instrutor do Canvas que incorpora lições do Canvas dentro do seu curso, é possível evitar problemas de navegador com conteúdo misto usando URLs protegidas do Canvas Guides. 

Comportamentos Conhecidos dos Navegadores

Chrome, Edge, Firefox e Safari usam HTML5 para exibir o conteúdo do site, promovendo uma experiência de navegação mais rápida e segura. Para melhor desempenho no Canvas, conteúdo do curso deve ser projetado para suportar HTML5.

Em navegadores como o Safari, o conteúdo inseguro nunca será exibido no navegador.

No entanto, no Chrome e no Firefox, você tem a opção de exibir conteúdo inseguro. Por favor, tenha atenção com as possíveis restrições e visualize conteúdos inseguros com cuidado.

Seguem-se problemas conhecidos no Chrome e no Firefox que podem bloquear ou criar conteúdo misto no Canvas.

Segurança no Chrome

Segurança no Chrome

O Google Chrome verifica se o conteúdo do website que você está visualizando é transmitido de forma segura. Se você visitar uma página em seu curso no Canvas que é conectada a um conteúdo inseguro, o Chrome irá exibir um bloqueio com um ícone de aviso [1] na barra de endereços do navegador.

Você pode escolher por ignorar a restrição de segurança e exibir o conteúdo de qualquer maneira clicando no bloqueio com um ícone de aviso e depois clicando no botão Carregar script inseguro (Load unsafe script) [2].

Permissões de mídia no Chrome

Permissões de mídia no Chrome

O Chrome tem suas próprias permissões de mídia com o navegador. Para usar a câmera e o microfone do computador em qualquer recurso do Canvas, permita o acesso ao Canvas por meio das configurações de permissão de mídia do Chrome. Este prompt aparece logo abaixo da barra de endereço [1]. Para permitir o acesso, clique no botão Permitir [2].

Segurança no Firefox

Segurança no Firefox

O Firefox verifica se o conteúdo do site que você está visualizando é transmitido de forma segura. Se você visitar uma página em seu curso no Canvas que é conectada a um conteúdo inseguro, o Firefox irá exibir um  de  [1] na barra de endereços do navegador.

Você pode escolher por ignorar a restrição de segurança e exibir o conteúdo de qualquer maneira clicando no bloqueio do ícone de aviso, clicando na seta para expandir suas opções [2], e clicando no botão Desabilitar Proteção por Enquanto (Disable Protection for Now) [3].

Especificações do computador

Para um melhor desempenho, você deve acessar o Canvas com um computador compatível com as versões mais recentes do navegador. Recomenda-se usar um computador com até cinco anos com pelo menos 1 GB de RAM.

Sistema operacional

O Canvas requer apenas um sistema operacional que possa executar os mais recentes navegadores compatíveis. O sistema operacional do computador deve ser atualizado com as atualizações e upgrades de segurança recomendados mais recentes.

Velocidade da Internet

Junto com as normas de compatibilidade e de internet, o Canvas foi cuidadosamente projetado para acomodar ambientes de baixa largura de banda.

É recomendável ter uma velocidade mínima de Internet de 512kbps.

Leitores de tela

  • Macintosh: VoiceOver (última versão para Safari)
  • PC: JAWS (versão mais recente para Chrome e Firefox)
  • PC: NVDA (versão mais recente para Chrome e Firefox)

Canvas em Dispositivos Móveis

A interface do Canvas foi otimizada para ser exibida em computadores, então, utilizando um dispositivo de tamanho reduzido como telefones pode não ser uma experiência agradável no uso do Canvas. Para a melhor experiência do usuário, baixe os aplicativos móveis do Canvas. Os aplicativos móveis Canvas requerem Android 6.0 ou posterior e iOS 13.0 ou posterior.

O Canvas oferece suporte limitado para navegadores móveis nativos em tablets. Para mais detalhes, consulte as diretrizes de navegador móvel com suporte limitado.

Navegadores móveis

Visite a loja da Apple (Apple Store) ou a Play Store (Android) para fazer download de navegadores móveis. Os seguintes navegadores são compatíveis com dispositivos móveis:

iOS

  • Safari (navegador padrão com suporte limitado do Canvas)
  • Chrome

Android

  • Chrome (navegador padrão com suporte limitado do Canvas)*
  • Internet
  • Firefox

 

*O navegador padrão do Android varia de acordo com o dispositivo móvel.